جهت ورود به تالار گفتمان سایت کلیک کنید

ترمیم باگ یازده ساله لینوکس

اگر در ارتباط با امنیت شبکه‌های کامپیوتری شبهاتی دارید، بعد از مطالعه این مطلب مطلع خواهید شد که امنیت شبکه‌های کامپیوتری آن‌گونه که گفته می‌شود قابل اعتماد نیست. اکسپلویت جدید و البته خطرناکی که قدمتی نه ساله داشته و در کرنل لینوکس وجود دارد به تازگی از سوی کارشناسان شناسایی شده است. اما هکرها از مدت‌ها قبل از وجود آن اطلاع داشته‌اند و در اختفای کامل سامانه‌های کامپیوتری را در معرض تهدید قرار داده بودند.

ترمیم باگ یازده ساله لینوکس


فیل اوستر، کارشناس حوزه امنیت به تازگی موفق شده است این حفره قدیمی را شناسایی کند. او در ارتباط با کشف این حفره به V3 گفته است: «پیاده‌سازی حمله بر مبنای این رخنه کار ساده‌ای بوده و ضریب موفقیت آن بسیار بالا است. در حالی که انتظار می‌رود فعالیت‌های مجرمانه در ارتباط با این آسیب‌پذیری از چند سال قبل آغاز شده باشد، با این وجود شناسایی این فعالیت‌ها به سختی امکان‌پذیر بوده است.» این کارشناس حوزه امنیت اعلام داشته است به دلیل پیچیده بودن فرآیندها تنها زمانی که تمامی ترافیک ورودی پروتکل HTTP را تحت نظارت بگیرد، قادر خواهید بود این اکسپلویت را استخراج کرده و در ادامه آن‌را در حالت جعبه شنی (sandbox) مورد آزمایش قرار دهید. این رخنه سطح کرنل به شماره CVE-2016-5195 قدمتی یازده ساله داشته که در همان روزهای آغازین از سوی لینوس تروالدز ترمیم شده بود. اما چند سال بعد کار او به واسطه ارائه یک به‌روزرسانی ناقص ماند و این رخنه دومرتبه فعال شد.

اوستر بر این باور است که هکرها از سال 2007 میلادی فعالیت‌های مجرمانه خود را بر مبنای این آسیب‌پذیری آغاز کرده‌اند. ردهت در این ارتباط گفته است: «حافظه هسته لینوکس بر مبنای یکسری عملیات ویژه حافظه دچار مشکل می‌شود. این مشکل نه تنها به یک کاربر بدون مجوز اجازه می‌دهد از این رخنه به منظور دستیابی به مجوزهای نوشتن استفاده کند، بلکه به او اجازه می‌دهد مجوزهای کاربری خود را به سطح مدیریتی ارتقا دهد. به طوری که یک کاربر عادی در نهایت می‌تواند به روت سرور دست پیدا کرده و حتا کل اینترنت را در معرض تهدید قرار دهد.» هر چند در وهله اول این حمله کاربرانی که یک حساب کاربری روی سرور دارند را نشانه می‌رود، اما این پتانسیل را دارد تا روی ماشین‌هایی که میزبان لینوکس هستند مورد بهره‌برداری قرار گرفته و به شما اجازه دهد یک فایل را اجرا کنید.

تعدادی از توزیع‌کنندگان لینوکس از اصطلاح Dirty COW برای توصیف این حفره استفاده کرده‌اند. اما شرکت‌هایی همچون ردهت که در زمینه طبقه‌بندی باگ‌ها فعال هستند از اصطلاح important برای این حفره استفاده کرده‌اند. شرکت‌های تولیدکننده توزیع‌های مختلف لینوکس به‌روزرسانی‌ سطح کرنل را برای ترمیم این حفره ارائه کرده‌اند. اوستر به تمامی کاربران لینوکس اعلام داشته است این باگ جدی بوده و در اولین فرصت به‌روزرسانی‌ ارائه شده را نصب کنند.

منبع شبکه

جهت تبادل گفتگو و حل مشکلات در باره این موضوع , کلیک کنید

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *